Help with Recurring Invoices/Payments - using paid $8.00/month

I was hoping for chat or phone support since we are paying but that doesn’t seem to be available, right?

Re: Recurring Invoice “Status”

Slowly moving over our invoicing to this system. Currently have 3 clients moved over. 2 of which seem to be behaving just fine with monthly billing on the 1st of each month using Stripe as our processor.

1 has an issue and we have no idea why. Client paid the first month and then second month nothing happened by sending the invoice, we were expecting the “Auto Bill Always” to auto charge them on their credit card, but that didn’t happen so I asked politely to go pay again using the new invoice requests sent by invoiceninja. so they did just that they paid it and the funds went thru. however the recurring invoice status is now listed as “viewed” rather than “active”

i am concerned that something is wrong again with this clients recurring invoice, i don’t want them to have to go online and pay every month!

any direct support on this bug is appreciated. not sure if i omitted any pertintent details

hi kozman,

Can you send us an email to include a screen shot of the recurring invoice page showing the settings and we’ll advise from there.


Can you check that “Auto-bill” is set to send date on Settings > Online Payments, if it’s set to due date it would get auto-billed later.

Hey Hillel :slight_smile:
I seem to have an issue with auto bill.
cards are saved as tokens, settings are set to auto bill on send date.
Back end shows sent but not paid.
Is there something I can check.

You can can click ‘View in portal’ then ‘Pay now’ to try to manually charge the card on file.

It may help to check the payment gateway’s API log for more details.

I think if I am thinking of the right button, the view client in portal button wants me to input the password for the client?

I’m assuming the issue is from using a different domain for the client portal so the app can’t tell that you’re logged in.

You should be able to workaround it by changing the domain in the link to