Failed upgrade from v5.3.25 to v5.3.27

The web UI gave me an error, “FormatException: SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data” when I tried to run the upgrade from v5.3.25 to v5.3.27.

There have been many upgrades where I or others have encountered significant errors with the self-hosted version in the v5 branch. I wonder if the move to v4 to v5 was premature for the self-hosters. Is there anything we can do to avoid having to wipe-out our installs every few upgrades?

Are there any related errors in storage/logs?

cc @david

It looks like the self updater picked the v4 release instead of the v5 release. Whilst i’ve put a fix in for this. You’ll need to manually copy the files over from this package.

Be sure to backup you .env and copy it back over when you finish copying the files.

@hillel No, laravel.log is clear of any errors.

@david Thank you for the explanation. Unfortunately, that’s going to be quite painful. I have to run some manual actions to get the SnapPDF workflow working based on other comments, which changes the vendor directory compared to the distribution, so blowing away all of that is expensive for me.

Hopefully upgrades are more stable going forward. I can kind of understand the edge-case in this scenario since it’s been a while since the last v4 update. I think I’ve been running v5 since the v4 update before this one, so there’s that.

I made a new install and copied over the .env file. So far all I had to do was reupload my company’s logo and everything else, including SnapPDF, seems to be working so far without any /vendor directory changes. Hopefully the v5 updates going forward will be more stable.

With the zip version I have exactly the same error situation.
There is no entry in laravel.log, Apache or php_errors.log.

Problem is therefore that neither with 5.3.27 nor with 5.3.28 a login is possible.

Update from 5.3.25 to 5.3.29 works fine without error.

1 Like