Error Seeding DB - Self Hosted

Ubuntu 16.04 with Nginx
InvoiceNinja version v3.1.0 (only to follow the guide). I also attempted with the most current version and received the same error.

Using this guide as a reference,

I get to Step 4 and run the php artisan db:seed command and receive the below error.

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘public_id’ in ‘field lis
t’ (SQL: insert into payment_terms (num_days, name, public_id, updated_ at<code>,</code>created_at) values (7, Net 7, 1, 2018-04-13 03:53:00, 2018-04-13 03:53:00

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘public_id’ in ‘field lis

I’m not familiar with the guide, you may want to use one of the ones listed here:

Thank you for the response. I attempted that guide first, the Ubuntu and Nginx, however received a different error. I thought it may have something to do with the guide stating it was Ubuntu and Nginx, but down in step 6 configure Nginx it mentions Apache2 config file. I proceeded following the steps anyway and ran into errors. I did not take a screenshot of the error thinking that the guide may have been wrong so I searched for another guide. I am not well versed in Linux so I am highly reliant on the guide. I will try the guide again.

Thank you.

So I followed the original guide shown here. I get all the way through without any errors. When I go to navigate to the site, all I see is a nginx welcome page.

I made sure to update the nginx config file with my internal domain name and server name. i.e. and when I nslooup my machine resolves to the correct ip.

I was finally able to get the site loaded.
I had to edit /etc/nginx/nginx.conf at the bottom “include /etc/nginx/sites-enabled/;" to "include /etc/nginx/sites-available/;”

I restarted nginx and then was able to load the setup page. Note: after entering db info and username and click submit, I got a timeout, however after waiting 5 minutes, the login page loaded and stated update completed. Now the site appears to be working.

I did refer back to the guide and ran the command at Step 7
sudo ln -s /etc/nginx/sites-available/invoiceninja /etc/nginx/sites-enabled/

but that did not seem to work.

Either way, site is now working, hope this helps someone else.

Glad to hear it’s working!

If one of the guides you followed has a mistake it would be very helpful if you could follow up with the author to have them correct it.