Error adding new gateway (Stripe)

Hi,

I am getting this error when adding new payment gateway:

Class ‘\Omnipay\GoCardlessV2\RedirectGateway’ not found: #0 [internal function]: Omnipay\Common\GatewayFactory->create(‘GoCardlessV2\Re…’)
#1 /… /vendor/omnipay/common/src/Omnipay/Omnipay.php(103): call_user_func_array(Array, Array)
#2 /… /app/Models/Gateway.php(199): Omnipay\Omnipay::__callStatic(‘create’, Array)
#3 /… /app/Models/Gateway.php(199): Omnipay\Omnipay::create(‘GoCardlessV2\Re…’)
#4 /… /app/Http/Controllers/AccountGatewayController.php(140): App\Models\Gateway->getFields()
#5 /… /app/Http/Controllers/AccountGatewayController.php(98): App\Http\Controllers\AccountGatewayController->getViewModel()

This looks similar to https://www.invoiceninja.com/forums/topic/error-after-upgrading-2-4-9-to-2-5-1-2-payment-gateways/ But trying to force database update did not fix the error. Can you please take a look ?

If you’re using the code from GitHub have you run composer install since updating the app?

composer install
Okay that’s something I have not done for some time. It does throw a lot of errors when I try to do that:

Loading composer repositories with package information Installing dependencies (including require-dev) from lock file Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for asgrim/ofxparser 1.2.1 -> satisfiable by asgrim/o
fxparser[1.2.1].
- asgrim/ofxparser 1.2.1 requires php ~5.6|~7.0 -> your PHP version (5.5.9)
does not satisfy that requirement.
Problem 2
- Installation request for doctrine/annotations v1.4.0 -> satisfiable by doctrine/annotations[v1.4.0].
- doctrine/annotations v1.4.0 requires php ^5.6 || ^7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 3
- Installation request for doctrine/collections v1.4.0 -> satisfiable by doctrine/collections[v1.4.0].
- doctrine/collections v1.4.0 requires php ^5.6 || ^7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 4
- Installation request for doctrine/common v2.7.3 -> satisfiable by doctrine/common[v2.7.3].
- doctrine/common v2.7.3 requires php ~5.6|~7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 5
- Installation request for doctrine/inflector v1.2.0 -> satisfiable by doctrine/inflector[v1.2.0].
- doctrine/inflector v1.2.0 requires php ^7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 6
- Installation request for zendframework/zend-stdlib 3.1.0 -> satisfiable by zendframework/zend-stdlib[3.1.0].
- zendframework/zend-stdlib 3.1.0 requires php ^5.6 || ^7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 7
- Installation request for zendframework/zend-validator 2.10.0 -> satisfiable by zendframework/zend-validator[2.10.0].
- zendframework/zend-validator 2.10.0 requires php ^5.6 || ^7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 8
- Installation request for zircote/swagger-php 2.0.11 -> satisfiable by zircote/swagger-php[2.0.11].
- zircote/swagger-php 2.0.11 requires php >=5.6 -> your PHP version (5.5.9) does not satisfy that requirement.
Problem 9
- doctrine/common v2.7.3 requires php ~5.6|~7.0 -> your PHP version (5.5.9) does not satisfy that requirement.
- doctrine/dbal v2.5.13 requires doctrine/common >=2.4,<2.8-dev -> satisfiable by doctrine/common[v2.7.3].
- Installation request for doctrine/dbal v2.5.13 -> satisfiable by doctrine/dbal[v2.5.13].

That’s for PHP installed on stock Ubuntu 14.04 server packages! Does this mean I have to move to Ubuntu 16.04 and PHP 7 ?

From the error it looks like you’ll need at least PHP 5.6.

Note: we’re likely to move to PHP 7 soon.

https://laravel-news.com/laravel-5-5-php-7-0