Error 500 after Update to 5.3.77

Every time the same problem: after update something is wrong.
The update from 5.3.39 to 5.3.77 causes error 500.


Are there any details about the error in storage/logs?

I am getting the same, using the Manual update and Automated update option i get a Error 500

my update breaks with log error Memory Size, but the app still works

1 Like

Increasing the PHP emory limit should help, this should be improved with our next release.

What’s the recommended value to increase to.

We don’t have a specific value to recommend, I suggest increasing until it works

1 Like

PHP Fatal error: Trait "Awobaz\Compoships\Compoships" not found in /html/invoiceninja/app/Models/Company.php on line 29

nothing in “laravel.log”

It should to help to copy over the latest zip

php artisan optimize
In Handler.php line 127:
Attempt to read property “company” on null

1 Like

this way works, the same problem like version 5.3.25?

@david do you have any suggestions?

Had the same problems.

Delete all data in directory /bootstrap/cache/

Restart web server… for me
sudo systemctl restart nginx


sudo php7.4 artisan optimize

since then everything works for me

1 Like

As it is a shared server i cant restart
I have deleted all data in directory /bootstrap/cache/

This update broke my installation too. I’m manually rebuilding.

I’m just manually uploading the new files from the unzipped 5.3.77 OVER my existing files. It worked to fix the last update which also broke my installation.

I’m sure there’s a faster way, but this way works, usually. I’ll report back if the update fails and I still have 500’s.

I have Done a Manual Update and even a fresh install of the files and replaced it with my .env file but i still get the Error 500 / Delete all data in directory /bootstrap/cache/ and still get the Error 500.

My programmer was able to make V4 compatible with PHP 8.0.
So now I have until the end of 2023 and will continue to work with V4.

What’s in /public/storage/logs/laravel.log??

The Log shows as [2022-03-31 07:37:02] production.ERROR: Class 'Codedge\Updater\UpdaterServiceProvider' not found {"exception":"[object] (Error(code: 0): Class 'Codedge\\Updater\\UpdaterServiceProvider' not found at /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Application.php:745) [stacktrace] #0 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(679): Illuminate\\Foundation\\Application->resolveProvider('Codedge\\\\Updater...') #1 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/ProviderRepository.php(75): Illuminate\\Foundation\\Application->register('Codedge\\\\Updater...') #2 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(659): Illuminate\\Foundation\\ProviderRepository->load(Array) #3 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/RegisterProviders.php(17): Illuminate\\Foundation\\Application->registerConfiguredProviders() #4 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(237): Illuminate\\Foundation\\Bootstrap\\RegisterProviders->bootstrap(Object(Illuminate\\Foundation\\Application)) #5 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(310): Illuminate\\Foundation\\Application->bootstrapWith(Array) #6 /home/redstonewebdesig/public_html/portal/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(127): Illuminate\\Foundation\\Console\\Kernel->bootstrap() #7 /home/redstonewebdesig/public_html/portal/artisan(37): Illuminate\\Foundation\\Console\\Kernel->handle(Object(Symfony\\Component\\Console\\Input\\ArgvInput), Object(Symfony\\Component\\Console\\Output\\ConsoleOutput)) #8 {main} "}

Is it possible you deleted the bootstrap/cache folder before copying over the zip? For other people deleting the folder has resolved this error.

You may also want to confirm this a new error added to the logs and not from before.