Error 403 after updating

I just tried to update it as it is described here and right after it when I try to access the /ninja/ in my website, I get the error 403. I already tried to upload the old backup .htaccess and also re upload the files. Didn’t work. Where’s the log? How can I fix it?

Which version did you update to?

Latest. I got and followed it here:

So v4.5.18?

If you’re seeing a 403 I suggest checking the web server error log, the app logs are in storage/logs

Alright, I says this:

[Tue Apr 07 11:38:04.291508 2020] [:error] [pid 988939:tid 140329633920768] [client] SoftException in Application.cpp:657: Directory “/home1/allan680/public_html/theninja” is writeable by group

Is it only a thing of permissions? I tried it too it keep failing. Maybe there’s the right file to config? I tried the htaccess only.

Maybe try to making the folder not writeable by group?

I set .htaccess and the main folder Ninja to 7 4 4. That’s readable and executable isn’t it? What am I overlooking at?

[Tue Apr 07 12:01:06.144958 2020] [core:crit] [pid 20018:tid 140329650706176] (13)Permission denied: [client] AH00529: /home1/allan680/public_html/theninja/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/home1/allan680/public_html/theninja/’ is executable

I tried several combinations and got it right. But now it’s returning the line above. Any idea?

[Tue Apr 07 12:29:28.311005 2020] [autoindex:error] [pid 74127:tid 140329701062400] [client] AH01276: Cannot serve directory /home1/allan680/public_html/theninja/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.shtml,index.xhtml,index.wml,index.perl,,index.plx,index.ppl,index.cgi,index.jsp,index.js,,index.php4,index.php3,index.php,index.phtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html) found, and server-generated directory index forbidden by Options directive

I got it. I had to add several different permissions and several files. Thank you.

I had this issue as well, here’s what worked for my install.

cd /path/to/ninja/
chmod 755 ./
chmod 755 ./public
chmod 644 ./public/index.php