Empty invoices (Self Hosted)

Good to all again, there is something that has me pissed, when I wanted to download several invoices within the section of invoices, I downloaded a file .tar with files but empty, no weight whatsoever.

What can be done?

https://imgur.com/RF9Elu0

I’ve tested this before on the test drive, and I’ve seen that it works.

The truth is that everything is fine, except this. My custom template can be the cause of this?

Please check for any errors in storage/logs/laravel-error.log

[2018-04-17 08:31:01] production.ERROR: PhantomJS - Invalid response http://.ddns.net/view/lggvhrvtbnygs95fr0e3ru9e6ute6d?phantomjs=true&phantomjs_secret=: {"context":"PHP","user_id":1,"account_id":1,"user_name":"TecnoMur Sistemas","method":"GET","url":"http://.ddns.net/test_headless","previous":"http://***.ddns.net/settings/email_settings","user_agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15","locale":"es_ES","ip":"192.168.100.1","count":1,"is_console":"no","is_api":"no","db_server":"mysql"} []

I can see that the DDNS is correct, but the ip that appears is the one of the router and not the server where invoinceninja is located. I have also tried with PhantomJs Cloud, with the same result.

Please check that APP_URL is correct in the .env file

Thank you for your quickly response, as always.

Yes, is correct. I checked it before.

/usr/local/bin/phantomjs

version 2.1.1

I’m sorry, I don’t understand your response.

Are you saying that APP_URL is correct or that PHANTOMJS_BIN_PATH is correct?

Ough, sorry.

APP_URL=http://***.ddns.net

It’s working and open to access from internet.

In your comment you wrote “the ip that appears is the one of the router and not the server where invoinceninja is located”. From that it sounds like you need to change APP_URL to link to the app not the router.