Emails not sending since v5.3.93

Since updating to v5.3.93…emails are not sending anymore. I’ve changed nothing else.
My cron commands and cron service are all exactly the same and running.

What could be the reason?

Are there any errors in the system logs?

@david do you have any thoughts?

No errors anywhere. None in the admin dashboard, none in the laravel.log. When I run the queue manually, it runs the command fine but nothing happens. No emails. I’ve double checked my .env and it’s all the same and correct. Stumped why this has suddenly happened.

I just performed a php artisan cache:clear then re-ran the cron command and now emails that were in the queue got sent. Any idea why this happens sometimes? It’s like the queue gets stuck.

I’m not sure, without any error logs it’s hard to say.

Something with permissions really got screwed up with the update to 5.3.93. Not sure what happened here but this was the same issue that caused this: PDF Generation - Error 500 - v5.3.93 - Permissions issue - #3 by kylegp - Self-Hosted | v5 - Discourse

Getting email send failures now.

Laravel.log below.

Not sure if related,

[2022-05-31 09:00:39] production.ERROR: Call to a member function filter() on null {“exception”:"[object] (Error(code: 0): Call to a member function filter() on null at /home/

Seems that payment emails aren’t working anymore either, I’ve tried everything.

Found a new issue, raised here:

Thanks for the error details!

cc @david


can you run /update?secret=secret

Did that already. I solved emails not sending, it was due to some permissions that went askew with this update and I had to clear the artisan cache for some reason. Not sure why. Anyway, emails are working again though I discovered a new issue which I raised above on Github regarding payment emails. That seems to be a reproducible bug.

1 Like