Emails are not sent even though no errors occur

I have been reading a bunch of posts on the forum about other people having this issue, but none of the solutions I have seen and tried have worked.

At the moment these are the email values in the ENV file (debug mode is also on):


I have seen some posts with MAIL_MAILER and others with MAIL_DRIVER therefore my env file contains both. I have also tried both tls and ssl.

When I press the button to send a reminder for an invoice I get a message saying that the invoice has been sent, but no message is ever received, also no errors appear in the system log.

I have tried to make the system generate an error by filling in a wrong password or by filling in a wrong host, but it still says that the invoice was sent successfully and no entry in the system log is created. I have also tried to set the MAIL_DRIVER and MAIL_MAILER variables to log in hopes of generating a log entry, but none are created.

Any ideas of what the problem might be would be highly appreciated!


What is the queue set to in the .env file? Maybe you’re queueing the jobs but not processing them.

The QUEUE_CONNECTION is set to database. I have tried setting it to sync as well, but that does not seem to work either.
I do read in the docs that it says something about queue workers, which I have not seen before.
Could this be the problem? Or does the fact that sync does not work either indicate that the problem lies somewhere else?

If you set it to database you’ll need to add the queue:work cron.

Do you see any error in storage/logs or the system logs when it’s set to sync?

I see this in the system logs. The language is said to Dutch, but it just says PDF > Pdf success.
This is new, so that is a good thing. Unfortunately, still no emails are received

@david do you have any suggestions?

I would suggest changing




After wards, send some test emails and then inspect the log files in storage/logs/

Inside there if you see the email output, it means the system is correctly generating the emails and attempting to send the emails. Which means the issue would be the SMTP configuration itself.

I set the MAIL_MAILER variable to log.
I do not see any other log file in storage after testing other than laravel.log, which does not contain anything relevant to the email

Any other ideas where the problem may lie?