Emailed invoice link

I am having issues with the invoice links going to clients. The url that goes to the client is http://client/invoice/hTce9eSQiXx5rteRVHfi6NU1PbkXGe10 instead of ‘…’

under the company > settings > advanced settings >client portal I have entered the full domain
Under company settings : Client portal is enabled.
under client>client portal : Client portal is enabled.
under client> authorisation : password protected invoices is enabled.

When I click ‘client portal’ from the admin at the top of the client settings page, the portal opens directly.

if I copy the http://client… url, remove the http:// and append it to my domain (…)
the link works, it asks me to set a password and then logs me in to my portal.It ju

The url being sent via the email is just not complete.


@david any thoughts?


What is the value of APP_URL in your .env file?

The solution to my problem was within your question. :slight_smile:
I don’t have access to the .env file as it is via plesk docker extension. There is just a page that says ‘Environment variables’.

There are no pre-filled variables that I need to add values for, so it has been an easter egg hunt to find out what I need to fill there.

The last (I hope!) piece of the puzzle was to add a variable APP_URL to the container environment variables.

I don’t know how common it is for people to use a plesk docker ext, or if it would be useful anyway, to have a list of compulsory variables that are needed to make the system work.

So, just to annoy the hell out of you guys a bit more, when I add the APP_URL variable the client log in page breaks.
I absolutely can’t even guess why or how this is possible.

(Login — Invoice Ninja)
I currently have the APP_URL in the variable set to my url.


I’ve had a look over the code, i don’t currently support different domains for the client portal, in particular whilst the domain may work, the invitation links will not be customized to the client portal URL.

Apologies David, I don’t fully understand.

InvoiceNinja is installed on it is the same url/domain in use everywhere?

Just to be clear, I have no current interest in using multiple companies. Just the one company using inv.ninj to manage my invoicing and customers.


Can we take a step back and can you advise your setup please?

Hi David, i was using the docker extension in plesk, but I tried your vps hosting set up option instead using my plesk panel and it worked.
I gave up on invoice ninja in a docker container managed by plesk. Too much headache!

Thank you for all the help.