Downloading proposals 0kb

When i try to download a proposal the download is 0Kb and offcourse does not open.

Self- hosted
version 4.5.5

Does the test link work on Settings > Email Settings?

It’s possible updating to the latest version will help.

Yes the link itself works. THe error is only when downloading… ok ill update to 4.5.7 on monday.

To be clear… have you tried the ‘test’ link on Settings > Email Settings?

Yes this works

Ok, let us know if upgrading doesn’t resolve the problem.

I downloaded the devoloper branche as i wanted to test the ticket system any way. Seems to work 4.5.7 (developer branche)

Glad to hear it’s working!

Hi there,
I am also having this issue and updating to 4.5.7 has not fixed it.

I did a Composer install after update. Maybe thatcdid the trick.

hi,

same issue here - but I am on version 4.5.11
I have tested different browser - same behaviour.
No error in console.
XHR call just return empty payload
For info, PDF download works like a charm with Quotes / Invoices - just broken with proposals.

Any help?
Any idea?
Tip?

did you do a composer install?

yes I did.


Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Package guzzle/guzzle is abandoned, you should avoid using it. Use guzzlehttp/guzzle instead.
Package league/url is abandoned, you should avoid using it. Use league/uri instead.
Package phpoffice/phpexcel is abandoned, you should avoid using it. Use phpoffice/phpspreadsheet instead.
Package illuminate/html is abandoned, you should avoid using it. Use laravelcollective/html instead.
Generating optimized autoload files
> rm bootstrap/cache/compiled.php || true
rm: cannot remove 'bootstrap/cache/compiled.php': No such file or directory
> php artisan view:clear
Compiled views cleared!
> php artisan clear-compiled
The compiled services file has been removed.
> php artisan optimize
Generating optimized class loader
The compiled services file has been removed.

bump.
Can’t be I am the only one with this issue, am i?

Hi jsavalle,
you are not the only one. I also have experienced the issue and it seems related to the old way of using phantomjs in the system. I’ve not been using ninja invoice for so long so I cannot confirm this.

Anyway, this has been fixed in the develop branch and you can either use this branch downloading it directly from Github or if you are like me and want to be a bit more in the stable branch, you can just replace the affected file in your installation.

Just get the code from this: https://github.com/invoiceninja/invoiceninja/blob/develop/app/Jobs/ConvertProposalToPdf.php

and replace your app/Jobs/convertProposalToPdf.php file with it.

that way your proposals will be exported exactly the same way your invoices are, so if you can download invoices as pdf, you will also be able to download proposals :wink:

Hey!

Just to thank you for the help, it did work now that I have integrated the fix, just like you mentionned.

Thanks!

Thanks for the update (and help @carcam), we’ll make sure this fix is merged into master with our next release.

hi, all the world fixed it?, because i changed .php prosale, and now download something, but not a proporsale that i edit, download a spam for example a api guide, or to register my web domain in a domain…whyhappen this?i try to do it in ampps and install it with nothing simple with ubuntu installation…can someone pass me a code that working?.
Thanks