Docker image - issues with file uploads - Failed to open stream: Operation timed out

I’m not linking anything up manually… And not following the guide exactly, since I have all my containers config in yml file. I get the env file from GitHub - invoiceninja/dockerfiles: Docker files for Invoice Ninja and I get the other things like applying chown and chmod.

Using standard approach with pre existing docker-compose.yml, pre-existing env file.
Then following with docker-compose up -d

My files are

dcoker compose
  Invoice_Ninja:
    image: invoiceninja/invoiceninja:5
    container_name: "REDUCTED" 
    env_file: .env_InvNNJ
    networks:
      - "REDUCTED" 
    restart: always
    volumes:
      - ${DOCKER_APPDATA_PATH}/ilr_inv_nnj/public:/var/www/app/public:rw,delegated
      - ${DOCKER_APPDATA_PATH}/ilr_inv_nnj/storage:/var/www/app/storage:rw,delegated
    depends_on:
      - mysql_db
env filel
# IN application vars
APP_URL="REDUCTED - public url" 
APP_KEY="REDUCTED" 

APP_DEBUG=true
EXPANDED_LOGGING=true

REQUIRE_HTTPS=false
PHANTOMJS_PDF_GENERATION=false
PDF_GENERATOR=snappdf
TRUSTED_PROXIES='*'

QUEUE_CONNECTION=database

# DB connection
DB_TYPE=mysql
DB_STRICT=false
DB_HOST=MySQL_DB
DB_DATABASE="REDUCTED" 
DB_USERNAME="REDUCTED" 
DB_PASSWORD="REDUCTED" 

# Create initial user
# Default to these values if empty
# IN_USER_EMAIL=admin@example.com
# IN_PASSWORD=changeme!
IN_USER_EMAIL="REDUCTED" 
IN_PASSWORD="REDUCTED" 

# Mail options
MAIL_MAILER=smtp
MAIL_HOST=smtp-relay.gmail.com
MAIL_PORT=587
MAIL_USERNAME="REDUCTED" 
MAIL_PASSWORD="REDUCTED" 
MAIL_ENCRYPTION=tls
MAIL_FROM_ADDRESS="REDUCTED" 
MAIL_FROM_NAME="REDUCTED" 

# MySQL - ommiting, DB already configured above. No mention of these variables in https://invoiceninja.github.io/en/env-variables/
#MYSQL_ROOT_PASSWORD=ninjaAdm1nPassword
#MYSQL_USER=ninja
#MYSQL_PASSWORD=ninja
#MYSQL_DATABASE=ninja
Caddyfile
################################################################################
# REDUCTED
################################################################################
REDUCTED public url{
    import header_noindex
    import tls_standard_email
  import logerror
# import loginfo

    root * /var/www/app/public
    php_fastcgi Invoice_Ninja:9000
    encode zstd gzip
    file_server browse
}

The difference in the configs is that I don’t use nginx as proxy, I use caddy (with many other containers behind it, including two public Wordpress instances). And I already have instance of MySQL for DB.
The caddy config is from https://github.com/invoiceninja/dockerfiles/blob/master/config/caddy/Caddyfile

Can you confirm that image published at Docker is not official? Then I get that there might be a problem in the image.