Disabling Cookie Consent

How would I deactivate that cookie consent banner on my self-hosted client portal? It collides with my own consent management.

We’ll add an option in the settings in our next release.

For now you’d need to comment out the code:


Thank you, Hillel. Fast and on-point support as always.

Is this still the only way to disable the cookie consent? Or has a setting been added. I’ve looking through InvoiceNinja settings, but can’t find a toggle to turn it on/off anywhere. Maybe I’m just overlooking it?

An option will be added in v4.6


Has this option to disable the self-hosted InvoiceNinja cookie consent been added? I tried adding COOKIE_CONSENT_ENABLED=false to my .env file and still getting the popup. Thanks!

Given that they said it would be in 4.6, and the current version is still 4.5.17, I’d assume that option hasn’t been implemented yet.

Oh- that is probably a correct assumption! I must admit I didn’t look at the version number- I assumed since the post was a year ago it was probably already done and I just couldn’t find any documentation on it. Dang! xD

Main reason I know the version number is that I tinker with my server a lot, and the MOTD tells me every time I login.

Back on topic, however, not sure if we’re gonna get an actual 4.6, or if all of that is getting rolled into v2. I just know they’re working hard.

To use this feature you need to use the develop branch of the code on GitHub.

We don’t plan to create a v4.6 release and are focused on v2.0 instead.

If you want to modify the code it’s defined here:


it would be fine to know how to disable the cookie consent for the client portal in v5.5.8 self-hosted / white label edition.

Thanks a lot.

No one can help?


@david is there a way to do this?

The code would need to be modified for this.

you could try accessing the selectors directly here:


and then display:none; them with css.

Thanks! That works.