Different Reply-To addresses

Hi all,

My wife and I are newbies and have been playing around a bit. I noticed that when sending an invoice, the reply-to field is set to match the Invoice Ninja user account, while the “Payment received” email uses the company’s email as its reply-to address.

These are two different fields in two different settings sections. They can be the same but obviously don’t have to. Is this a bug or a feature? And in case it’s the latter: Is there any way to make Invoice Ninja use just one of them for all client emails without using the company’s email as the Invoice Ninja account email?

Best regards

I’m having trouble replicating the problem. Are you using invoiceninja.com or are you self-hosting, if self-hosting which version?

For all client emails the app uses the reply-to setting on /settings/email_settings if it’s set, otherwise it should use the user’s email address set on /settings/user_details.

Shalom Hillel, we’re using invoiceninja.com and I think I located the problem. Settings / Email Settings is pro and while we were in the 14 days testing period, that email address was used for both pre- and post-payment emails. Now that we don’t have access to pro, that pro setting isn’t applied anymore to pre-payment emails but is still used for post-payment emails. Since we’re not pro, we can’t change it. As a side note, I would suggest that the default reply-to address would be the one at Settings / Company Details because these are the details that Invoice Ninja uses for the invoices. It would make much more sense than the User Details email address, which is in itself quite irrelevant for the clients (or so it seems to me).

I’m not sure. I’ve reviewed the code, once the trial ends the user’s email should be used in both places.

If you want to add contact@invoiceninja.com as a test client and send both emails it could help to debug the problem.

Ok, will do that tomorrow. One other thing: Whenever we open an existing invoice (sent, paid - doesn’t matter), the invoice number is automatically changed to 0001 (which happens to be the number of another invoice). So basically every time we enter an invoice and intend to change something and/or send it, we have to restore its original number manually.

Are you using the LastPass browser extension? It may be auto-filling the form.

Yes, it was caused by LastPass. Any idea how to prevent it without disabling LastPass for InvoiceNinja.com?

Re email address: Got around it by setting user email address to match the email in the pro settings. So now the pre-payment emails have the same reply-to as the post-payment emails.

Try enabling this setting in LastPass: Settings > Advanced > Allow pages to disable autofill

Glad to hear you found a solution!

“Allow to disable autofill” did the trick. Thank you and shkoyech! :slight_smile:

Great to hear, thanks for letting us know!

I should probably open a new topic for this but am embarrassed to say that I can’t find the button for a new topic on the forum page…

My question is: What does the “accepted credit cards” limitation under “Edit gateway” actually mean? I only have Visa and Mastercard checked but just got paid with an American Express card (which in my case generates a much higher commission). Does this setting only change the images on the payment page but has no effect on the actual payment?

Thanks ahead!

The new post form is at the bottom of this page:


The accepted cards setting in Invoice Ninja just control which logos are shown, limiting card types would require changes in your payment gateway’s portal (if it’s supported).

Aha, I understand. Thank you for clarifying. I would suggest renaming the setting to “Accepted cards logos” to avoid this misunderstanding by newbies such as myself :slight_smile:

Agreed, we’ll include the change in our next release.

The new topic form appears on https://www.invoiceninja.com/forums/forum/support/ but not on https://www.invoiceninja.com/forums/

I got to /forums/ because of Chrome’s URL autofill and didn’t notice it’s the wrong address because it also shows the complete topic list. I guess it confused me because there’s only one forum so the topic list is the same on both pages.