Delete invoice number


I created an invoice, lets say with number 300, and before saving it, my computer was powered off.
When i tried to create it again, the invoice number was 301 and i couldn’t create the invoice 300.
Is it possible to delete the invoice 300 in order to have invoice consistency ?

thank you


You would need to update the invoice to have a different number (ie, 300-DELETED) and then delete it, that would free up the number for uses in a different invoice.

but i can’t even see the invoice 300.
There is no invoice 300, there is only 299 and the next one i try to create is numbered 301.

Check the generated invoice counter in invoice settings - it’s probably showing 301. Try setting it to 300.

It is set to 301, but even if i set it to 300 it doesn’t actually changes when i save it.

Is there an invoice in the system with the number 300, I suggest using the search in the top right to check.

No there is not.
But i can see there is in the database.

Change the invoice counter directly in the DB in the accounts table (column name is invoice_number_counter)

You mean invoices table ?
But i see there the invoice.
The problem is that i don’t see the invoice 300 in the invoiceninja.

Can I change something in the DB to make visible the invoice 300 instead of deleting it ?

Problem fixed by touching the Database.

thank you all very much