Custom labels not working for groups

I have been playing around with invoice design in v5 self-hosted. it’s really good!

I tried to change the text for “Unit Cost” under Localization → Custom Labels
==> the change does not apply to groups under this company (and there is no option to have custom labels in groups)

Is there a solution to this?


Thanks for reporting this, @david any thoughts?

i’ll look into this.


So the UI isn’t giving the user an option to add custom translations to groups. From memory i think we need to keep this at the company level as the complexity of managing dynamic variable down into groups / clients creates some ugly edge cases.

1 Like

OK, I understand. It’s actually fine with me at company level - but could it still apply to groups?

Hi @david :slight_smile:

Just giving this issue a nudge, as I can’t find a way around it. I have to use groups for my invoicing, and it works great, but if I do this, custom labels do not work.

You said it has to be kept at company level, which is really fine, but custom labels defined at company level should still apply to all groups within the company?

@stephlegrand that’s correct, the translations will be applied everywhere when set at the compeny level… are you seeing something different?

I am using v5.1.43-C45, and it is still showing standard labels, not custom ones.

I am using French language, just in case it makes a difference.

Actually, even at company level, custom labels are not displayed :frowning:

Can you please show a screenshot

Sure :

First is the screen where I define labels
Second is the screen with generated PDF invoice, the column headers should have changed

I’m not able to recreate this.

One thing to note, is that after creating the custom label, you will need to force the application to regenerate the PDF, to do this, open up the invoice and save it again, and then view the PDF, it should update.

Yes, I understand this, and the PDF was created after the labels. I don’t understand what is wrong then.

I am using a custom template for invoices, so I thought it may have an impact. I tried to revert back to a standard template, but I bumped into something unexpected: I could not save the new settings, and then I got an error 500 with this in the error logs:

[Wed Apr 14 08:14:48.925899 2021] [proxy_fcgi:error] [pid 32078] [client XX.XX.XX.XX:53028] AH01071: Got error ‘PHP message: PHP Warning: require(/var/www/ninja/public/…/vendor/autoload.php): Failed to open stream: No such file or directory in /var/www/ninja/public/index.php on line 26PHP message: PHP Fatal error: Uncaught Error: Failed opening required ‘/var/www/ninja/public/…/vendor/autoload.php’ (include_path=’.:/usr/share/php’) in /var/www/ninja/public/index.php:26\nStack trace:\n#0 {main}\n thrown in /var/www/ninja/public/index.php on line 26’

I was not able able to fix it, so I had to restore everything from last night’s backup.

You may be able to fix it by running composer install --no-dev

1 Like

ok so, thanks to this I was able to go back to a standard template, but the column headers are still the standard ones when generating a new invoice. I am at a loss :sweat_smile:

@ben any thoughts on this?

I just did a clean reinstall of the latest release (using the same database, the only thing I kept was my .env) It went without a hitch, I just had to reupload the group logos. so actually it’s a good test in case something goes wrong, it’s remarkably robust.

However the standard column headers are also remarkably robust, they won’t budge, so my problem remains :expressionless:

I am not able to replicate this either. Can you replicate your issue on

@ben no, I cannot. Custom labels seem to work even for a foreign language on the demo site.

As the problem happens for me even with a fresh install, is there a way that there is something in the database ? Should I reinstall absolutely from scratch? Or is there anything else I can check before I do this?