Company Logo not display within invoice

Please create a new post for further help with this issue.

Hello together,
I also had to struggle with the logo being broken on the PDFs, but visible and accessible everywhere else.

With phantomjs it worked fine but slow. When I switching to snappdf the problems started to appear.

The problem seems to be exclusively with snappdf and the headless chromium browser which it uses.

I installed and configured invoiceninja in Plesk on debian 11 via the git repository. Apparently headless chromium has trouble opening the HTTPS link to the logo.
Unfortunately no suggestion in this forum has solved the issue.

My solution, after days of testing:
I created another subdomain that has the public storage as root directory.
In the public .htaccess file I redirect all storage links to this subdomain.

RewriteRule ^storage/(.*)$ https://invoicestorage.example.com/$1 [R=301,L]

Now the logo is finally displayed correctly everywhere!

Thanks for sharing this solution!

cc @david

@Alibaba97

In your web servers config, what’s defined as document root?