Clients unable to view Quotes in client portal

Hi All,
new here and new to invoice ninja. had to fiddle around quite a bit during setup but all working now - amazing job with this software!!!

  1. I’ve noticed (as per the title) in the client area everything is viewable except for quotes.
    It happens when you click on the “view” button on every quote - gives an error message of {“message”:“You are not authorized to view or perform this action”}

Invoices etc can be viewed - only seems to happen with quotes, I don’t think i’m the only one from looking at other threads but not seen just quotes.
I’ve tried disabling and re-enabling the module.
Refresh data and php artisan optimize…

  1. Also have the red error triangle for cron jobs but they are set up on my cron jobs correctly as per the install. EDIT - This issue has been solved - must have been a time issue.

  2. Have just noticed when on a client profile - if you click on client portal it gives a 404 not found - when I click on the back to my domain link it takes me to my domain/client which gives a warning of:
    Not Found
    The requested URL was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Not sure if these are bugs or if I’m doing something wrong :slight_smile:

Thanks :slight_smile:


  1. Can you please check if the APP_URL value in the .env file has a trailing slash

  2. @david any ideas to debug this?

Hi Hillel,
I double checked this last night as I saw this somewhere else. I can confirm no trailing slash


Hi there!
Do you happen to be running Cloudlinux? I found that the client portal (specifically whilst viewing quotes) was unstable while using “ALT” versions of PHP, and thus needs to be changed to an “EA” version.
Here’s a guide on how to do it in cPanel:

And as hillel mentioned above triple check your .env file, sometimes we miss a directory or a / in the incorrect place. Make sure you run php artisan optimize or if you’re using shared hosting after editing your .env file.

Also double check your .htaccess file is correct for those error 404s. Ensure you are using the latest v5 release. A fix for the .htaccess file was released back in December 2020.