Can't attach PDF Documents

Yes, I ran a get request prior to trying all of this to get the ID in the first place.

Would it help if I provided you credentials to our account?

@david 5344 is the invoice I’m working out of

Sorry if we are going in circles here:

I believe the root cause is multipart/form-data and a bug in PHP,

The fix is to add a body parameter

_method

with the value

PUT

Do I need to include an API-Secret?

The API secret isn’t required on our hosted platform.

I notice a token was included in an earlier post, if this isn’t a test company please delete the token in your account and create a new one.

Can you please just tell me what I’m missing here? I keep getting the same error “Method not supported for this route”

I suggest first getting the request working using the cURL sample above and then trying to port it to Zapier.

@david @hillel Ok potential progress

I kept all the steps consistent and instead tried it in a put step and got a new, more hopeful error. Problem is that I do have a paid plan.

"The app returned "Upgrade to a paid plan for this feature."

Uploading documents requires an enterprise plan.

@hillel Ok, I’ve upgraded to Enterprise and the put request is successful, BUT there is no document attached to the invoice. I tried running everything the same with a post zapier step but still getting the “method not supported” error.

Have you been able to make it work using cURL?

Yes it works with CURL, but I can’t use Curl for this. I need it to be done with zapier because we aren’t going to be downloading the pdfs locally at all.

We use zapier’s integration with a software that generates pdfs, outputs a url, and then attach that url to the invoice.

We did this no problem in v4 and in v5 it’s impossible.

Comparing the screenshot above to the cURL request I see some differences, for example the app is expecting the file index to be documents[]. Also, cURL is sending a POST request with a _method=PUT parameter.

I don’t know that you can indicate a method within a method in Zapier. Is there any examples anywhere of this being done outside of Curl?

Is there any way to create a native integration within zapier for this? This one little step is holding our entire company back from moving to v5. There has GOT to be a way to do this.

In the screenshot I see method:put, it should be _method:put.

We can look into this in the future but it would take time.

I got the request itself to work with adding method _put, but it’s not liking the file being passed along as a url. How can I get this to accommodate a url as the file?

@david @hillel Would I be able to CC either of you in a thread I have with zapier? Perhaps we can collaborate on a way to make this work?

Sure, feel free to CC contact@invoiceninja.com on the thread