Cannot view / print invoices - getting a CloudFlare error

We installed v5 yesterday, I was able to view and print invoices, this morning I am getting a CloudFlare error, it references a Google data center IP address in Iowa that has nothing to do with our infrastructure. Anyone know what’s going on and how to fix it?

It looks like Cloudflare has been configured with specific security settings. You’ll need to wind back the security levels in Cloudflare.

David: We aren’t using CloudFlare on this domain. The IP address listed isn’t used by my computer, its network, etc. It is a Google datacenter IP.

open the browser console and advise the domain the app is trying to access.

This is quite odd, console says I am accessing my domain.

But, it is now working, after I unblocked port 80 & 443 on the firewall. Why would invoice printing require an incoming connection to the external world, shouldn’t that be self contained?

Yesterday, we were using Cloudflare as a proxy, everything worked. When things didn’t work, I thought “let’s get rid of the Cloudflare proxy”.

the PDF resolves from the URL of the client portal, so this makes sense if you have blocked portal 443/80.

Looking at the CloudFlare Firewall Events log, I learned something was calling:

We are able to use Phantom if we add this firewall rule to Cloudflare:
Allow when: http.request.uri contains “/phantom/invoice”

My preference would be to use snappdf, however after fighting with snappdf for several hours, I concede defeat. Perhaps its wrinkles will be worked out in a year or so.