Cannot remove empty line in invoice

Hi there,

I have an issue where I create an invoice and have 1 line with a product and price.
the second line which is empty creates a 0,00 line on my invoice…

that line does not have the RED stopsign/toggle to delete the line.

Another thing is that the alignment of my line heads such as: “amount, unitprice, total” are not well aligned with the data below it. I

How can i get rid of this line? Please help, as I need to invoice my customer asap…

I think the problem is because of the decimal separator, which currency are you using?

You can change the alignment by adding the following code in the ‘Styles’ section of Customize Design. Note: you need to switch from ‘form’ to ‘code’.

“costTableHeader”: {
“alignment”: “right”
},
“qtyTableHeader”: {
“alignment”: “right”
},
“lineTotalTableHeader”: {
“alignment”: “right”
}

I am using EURO as a currency. I however do remember that i changed the decimal in the database prior to this versio, because i needed a “,” as a seperator and it kept giving “.”.

I tried adding the styles in “code” on the correct form, but the changes do not reflect.
BEfore adding tot the code, i put a “,” after the last current line, because i think the code would get broken due to following lines underneath…but still no change…

Any ideas?

You are correct that you’d need to add a comma after the last line. Are other changes being reflected in the preview, maybe double-check that you added it to the ‘Styles’ tab.

Hi, i added to the “styles” tab, but other changes such as changing a “true” to “false” about making the invoicenumber bold didn’t reflect in the preview…

Might it be that my serverfolder permissions are not valid?

I’m not sure.

Custom invoice designs are stored in the database so I wouldn’t think it’d be a permissions issue. Try comparing the behavior against our hosted app.

Are there any JavaScript errors in your browser’s console?

1 problem is “fixed” for now. I went into the database and changed the currency seperator back to what is was, (which is faulty actually)

thousand_separator = ,
decimal_separator = .

For the netherlands this should be the other way around. Is there a way I can fix this and have these two in a correct way without the application behaving so weird?

Still working on the CSS part. In what table is it stored ?

The problem with comma separator should be resolved in a future release.

The custom design is stored in the custom_design field of the accounts table, but you should see the preview update in real-time so I’m not sure that’s the problem.

With so many people using this, who also have the comma seperator issue. How do most people work around it?

I think i found the issue with the css editing…after looking closely at the code (doh! -> homer voice)

i copy pasted: “ instead of using ". SO i am working the edits now, to see if they stick :wink:

I’m not sure, this hasn’t come up much. That said, someone recently created a pull request with a comma separator for a new currency.

https://github.com/hillelcoren/invoice-ninja/pull/434

So that means if you think the code is good and working, you will implement it in a coming release ?
Would be great before the end of the year when the accountants check my invoices…

You can fix the blank line by changing the references to cost == '0.00' in public/js/built.js to cost == '0.00' || cost == '0,00'

Assuming you update the currencies table the PDF will use the comma separator but the form inputs will still use a period. Is it a problem that they’re different?