BUG: php7.4 error while installing Ninja v5.3.18

Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.4.0”.

run by Apache2 and php7.4 module and mod re-write enabled.

VirtualHost *:80>
ServerAdmin admin@example.com
DocumentRoot /var/www/html/ninjas/public
ServerName mydomain.ca
ServerAlias www.mydomain.ca

 <Directory /var/www/html/ninjas/public>
    Options +FollowSymlinks
    AllowOverride All
    Require all granted

 ErrorLog ${APACHE_LOG_DIR}/error.log
 CustomLog ${APACHE_LOG_DIR}/access.log combined
 Include /etc/apache2/conf-available/php7.4-fpm.conf

any solution?

What do you see when you run php -v

PHP 7.4.24 (cli) (built: Sep 23 2021 22:09:39) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.24, Copyright (c), by Zend Technologies

@david do you have any suggestions?

should i try nginx under the same php7.4 and same root folder for v5.3.18? or it doesnt matter…not sure I will see the same error under nginx…i already prepared the vhost but not enabled yet because i want to try and fix the error under apache2

execute phpinfo() in blank script in your webroot. i would guess you are not running php7.4

ok let me try…will give you feed back

strange…info.php shows php7.3 eb=ven though the nginx vhost i used is set to use 7.4. …but then apache using php7.3 as default though php7.4 is enabled…so not i can see Ninja in action once i disable php7.3 with a2dismod php7.3 …why though? my apache2 forced to use the lowest php or what?

ok I got my apache issue sorted out so now i can see Ninja spinning and back flipping in the sky :blush::blush::blush:…thanks a lot for pointing out info.php as troubleshooting method. i am new to apache…i never wanted to use it but now i want to use as my backend and let nginx lead…my next is how to secure the site and to make ssl score A+ with the apache vhost

Good morning sir!!..I just attempted to setup ninja and now after filling out thw whole form to the last part of user name and email, the form reset bring me back to initial setup. I tried it many times, delete all files from root folder and unzipped all files again, went through setup, PDF test pass…in the end, same setup loop.

<VirtualHost *:80>
ServerName myninja.com
ServerAlias www.myninja.com
DocumentRoot /www/public_html/payment/
<Directory /www/public_html/>
Options +FollowSymLinks
AllowOverride All
Require all granted

ErrorLog ${APACHE_LOG_DIR}/cashkudi.error.log
CustomLog ${APACHE_LOG_DIR}/cashkudi.access.log combined
Include /etc/apache2/conf-available/php7.4-fpm.conf
<FilesMatch ".+\.ph(ar|p|tml)$">
    SetHandler "proxy:unix:/run/php/php7.4-fpm.sock|fcgi://php74.localhost"

correct me please…thank you

so i got it working under nginx…I login and when i try to upload a logo, it shows successful but logo does not appear…did i miss anything?

NINJA V5.3.21

SOLUTION to missing logo or uploaded logo not showing…make sure you are ACCESSING YOUR NINJA by a domain name and domain set in your .env …localhost wont show logo