Any Concerns going from v3.8.1 straight to v3.9.2?

I’ve been pretty busy lately and my schedule along with open invoices has prevented me from doing the upgrade sooner.

3.9 looks like a decent sized update (really want the Fail2Ban!), just wondering if there is anything I should know before jumping from 3.8.1 right into 3.9.2


Obligatory “I’m just a fellow user and not one of the devs”, but there shouldn’t be any issues. All the features were added in 3.9.0 and .2 is just the second minor bugfix release.

I just let mine update whenever a new version drops and haven’t had any issues.

So update went fairly well. However I’m not seeing anything under “documents” in the client portal, but the document(s) is listed under the specific invoice. Additionally if I try and set the “rows” under documents in client portal I’m getting an error.

laravel-error.log shows:

ninja/vendor/laravel/framework/src/Illuminate/Database/Connection.php [Line 729] => SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘document_date’ in ‘order clause’


Nevermind a quick reboot fixed it. I could have probably just restarted all my web based services to resolve it also, but a reboot was easy enough. I’ll leave this up for reference.

Darn it, I tried it in another browser with all the cache and cookies flushed and the issue came back. It seemed to be unrelated to rebooting the server.

Chrome Browser is giving the error when attempting to change the “rows” option in “Documents” section in the client portal and the documents section is also missing all documents:

DataTables warning: table id=DataTables_Table_0 - Ajax error. For more information about this error, please see

Same Laravel-error.log entry as before to go along with that chrome browser error

production.ERROR: Illuminate\Database\QueryException [42S22] : /ninja/vendor/laravel/framework/src/Illuminate/Database/Connection.php [Line 729] => SQLSTATE[42S22]: Column not found: 1054 Unknown column 'document_date' in 'order clause'

How frustrating.

Well that’s strange… I hit the sort by name tab under the Documents section of the client portal and the documents reappeared. However I’m getting an error still if I hit sort by “Document date” or “Size” in the Documents section of the client portal…

I’m pretty confident at this point it’s a bug and not related to my setup.