All Languages and Currencies not selectable in new install

Hi,
I’ve got a new docker based install, based on the invoiceninja/invoiceninja:5 docker image. This is currently using v5.3.88-C84.

The docker-compose creates the nginx server, app server and mysql server successfully and no errors are shown in the logs.

When logging in for the first time using the first-time credentials, the pop-up to create a new company only shows a small number (7) of languages and (8) currencies. None of these are English and British Pounds!

Everything is default and being accessed directly to the NGinx server rather than through a proxy or load balancer.

If this pop-up is cancelled and I go into the Localization settings, the same Languages and Currencies are shown.

Looking at the Developer Tools, Network Tab, I’m not seeing any failures in loading content.

Any ideas? Is this a bug?

Thanks.

Hi,

It may help to run php artisan optimize or load /update?secret= in the brower

I ran “php artisan optimize” in the App container within the console it gave the familiar output for clearing of the cache:

$ php artisan optimize
Configuration cache cleared!
Configuration cached successfully!
Route cache cleared!
Routes cached successfully!
Files cached successfully!

Cleared the cache in the browser, but no change to the list of languages or currencies unfortunately.

Thanks

@david can you please advise?

For reference, this is what the drop-downs look like on the clean install:

Thank you.

And the currencies drop-down:

Hi there,

I got the exact same issue. Only a hand full of languages and currencies. I need German language and Euro. But don’t know how do add.

I use Invoiceninja via docker container from original source at hub.docker.com >> invoiceninja/invoiceninja:5

Thanks in advance.

Christian

@david are you aware of a fix for this? php artisan optimize has already been tried.

The fix here is to run /update?secret=secret

In the latest release we’ve integrated the update command into the self update process so this should hopefully not be required in the future.

1 Like

@david Thank you so much. This helped me.

The issue can be closed.

1 Like

The update?secret= resolved it for me as well.

I’ll test against a new version as well and look forward to this being fixed for new installs.

Thanks for all your help! Appreciated.

2 Likes

I just set up a new docker container with the current version v5.3.90-C84 and had the exact same issue.

But a fix would be nice to save new users a bit of time debugging.

Thanks,
Gijs

@ecomsilio

was this using our standard docker compose from the dockerfiles repo?

Yes, all default.

Also SSL is not working and I’m currently not sure why.

I’ve had an SSL issue with the docker install as well, due to the reference to the pdf.min.js ignoring that everything else was being accessed over SSL by a reverse proxy and REQUIRE_HTTPS was set to =true.

PDFs are able to be download but not previewing and I’ve tested without the reverse proxy involved with the same issues. To get around the pdf.min.js issue about I ended up doing a body rewrite on the reverse proxy to correct it, which isn’t great.

All from the docker-compose.yml by cloning https://github.com/invoiceninja/dockerfiles.git.

Next step for me is to look at the docker build, deconstruct it and correct it as this has worked in other environments, just not docker driven which is the ideal for me.

Thanks

@ecomsilio

.91 has the first issue fixed.

in regards to SSL, how are you terminating the SSL?

You may need to add

TRUSTED_PROXIES=*

To the env file

I already tried this. When I start docker, it says:

dockerfiles-db-1      | 2022-05-25T10:44:14.114781Z 0 [Note] Found ca.pem, server-cert.pem and server-key.pem in data directory. Trying to enable SSL support using them.
dockerfiles-db-1      | 2022-05-25T10:44:14.117070Z 0 [Note] Skipping generation of SSL certificates as certificate files are present in data directory.
dockerfiles-db-1      | 2022-05-25T10:44:14.117102Z 0 [Warning] A deprecated TLS version TLSv1 is enabled. Please use TLSv1.2 or higher.
dockerfiles-db-1      | 2022-05-25T10:44:14.117127Z 0 [Warning] A deprecated TLS version TLSv1.1 is enabled. Please use TLSv1.2 or higher.
dockerfiles-db-1      | 2022-05-25T10:44:14.118249Z 0 [Warning] CA certificate ca.pem is self signed.
dockerfiles-db-1      | 2022-05-25T10:44:14.119101Z 0 [Note] Skipping generation of RSA key pair as key files are present in data directory.
dockerfiles-db-1      | 2022-05-25T10:44:14.119815Z 0 [Note] Server hostname (bind-address): '*'; port: 3306
dockerfiles-db-1      | 2022-05-25T10:44:14.119891Z 0 [Note] IPv6 is available.
dockerfiles-db-1      | 2022-05-25T10:44:14.120080Z 0 [Note]   - '::' resolves to '::';
dockerfiles-db-1      | 2022-05-25T10:44:14.120136Z 0 [Note] Server socket created on IP: '::'.
dockerfiles-db-1      | 2022-05-25T10:44:14.122879Z 0 [Warning] Insecure configuration for --pid-file: Location '/var/run/mysqld' in the path is accessible to all OS users. Consider choosing a different directory.

Regarding currencies and languages not working: I have the same problem.

Would I run this like?

https://SERVERIP:SSLPORT/#/update=secret=MYSECRET

because I tried it like this and nothing happened, basically the same page reloaded

The correct link is:

https://SERVERIP:SSLPORT/update?secret=MYSECRET