After update to v5.5.117-C115, payment type no longer auto completes

I’ve just updated to v5.5.117-C115. When I go to create a new payment for an invoice, I get the side pane that looks like this, as expected:


However, when I click into the Payment Type field now, I don’t get an auto complete list of payment types to choose from:


You can see that even if I start typing “Interac E-Transfer” for example, it doesn’t offer any suggestions either:


This was working in 5.5.104, which I was running previous to this version.


Do you see the payment types listed when viewing the payments table?

@hillel - I do, yes. The payment types are all in the database table. Checking past payments in the web interface also correctly maps their payment type ID to the payment type and displays the correct/expected payment type for each payment. Also, if I’m using the mobile app, tapping the Payment Type field still drops a menu down to select the payment type.

It just seems to be the web interface that broke this functionality after the latest update (or somewhere between 5.5.104 and now). I also tried private browsing windows in other browsers to see if it was some weird cache between versions in my main browser, but this didn’t change anything. Still no auto complete menu in the Payment Type field in the web interface when entering a payment.

Thanks for the info, we’ll look into it.

We’ve checked in a fix for this issue, it will be available in the next release.

Until then you can workaround the problem by setting a default payment type on Settings > Payment Settings.

We’ve checked in a fix for this issue, it will be available in the next release.

Awesome, thanks!

Just updated, confirmed fixed. Thanks again!

1 Like

Glad to hear it, thanks for the update!