404 error unless index.php in URL

I thought I follow the guide pretty well, but seems I am missing something. I can only load invoiceninja from subdomain.domain.com/index.php. navigating to subdomain.domain.com redirects me to subdomian.domain.com/dashboard with displays 404. Also, even though I can access from index.php, I still get 404 errors for manifest.json and logo which are visible in js console on chrome…

Other posts indicate to ensure mod rewrite is enabled which it is… not sure what the gap is… maybe RewriteBase isn’t configured properly? (already tried a few variants there with no success…)

$ a2enmod rewrite
Module rewrite already enabled

public .htaccess contains the following:

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews

    RewriteEngine On

    # Redirect Trailing Slashes...
    RewriteRule ^(.*)/$ /$1 [L,R=301]

    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]

    ## enforce https access
##      RewriteCond %{SERVER_PORT} 80
##      RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L]

    # http://stackoverflow.com/a/20865084/497368
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # In case of running InvoiceNinja in a Subdomain like invoiceninja.example.com,
    # you have to enable the following line:
    RewriteBase /

root .htaccess contains the following

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteRule "^.env" - [F,L]
  RewriteRule "^storage" - [F,L]
  RewriteRule ^(.well-known)($|/) - [L]

  # https://coderwall.com/p/erbaig/laravel-s-htaccess-to-remove-public-from-url
  # RewriteRule ^(.*)$ public/$1 [L]

VirtualHost *:443 within apache ninja.conf contains the following directory info pointing to /var/www/html/ninja/ninja/public/

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin webmaster@host.com
        DocumentRoot /var/www/html/ninja/ninja/public
        <Directory “/var/www/html/ninja/ninja/public”>
          Options +FollowSymlinks
          AllowOverride All
          Require all granted

I don’t see any interesting logs, but console does who 404 on index.php/logo and index.php/manifest.json