403 after first reboot

So, I’ve managed to reproduce this several times, but I can’t figure out how to fix it. I’ve installed Invoice Ninja 4.2.2 on a CentOS VM using the linked directions. It works fine until I reboot the VM. Then I can’t get anything other than a 403 error.
Looking at the site directory the permissions look correct, and running the suggested fix in the documentation doesn’t work. There are instances of php running as apache that seem to be coming from the www.conf file, but I can’t seem to get anything to trigger from the ninja.conf. At lease that is my suspicion at this point, but I’m a bit of a NOOB here.
The only things I have done to the VM not listed in the CentOS how to are install open-vm-tools, allow http and https in the firewall, and manually set the database info in the .env.
Could someone please help me get this working?

sounds like a SELinux issue… try disabling SELinux and see if that fixes it.

You are correct. I ran setenforce 0 again and things are working. The how to says that disables it, but evidently it doesn’t survive a reboot. Looks like it get to read up on how SELinux works. Thanks for the help!

You’ll need to find the config file for SElinux, and set the field to disabled, reboot and then you should be good to go!

I figured out how to set it to permissive and have that survive a reboot.

Great debugging Dave, thanks!